“You must upgrade the ports-mgmt/pkg port first.”

After a fresh install of FreeBSD 10.2 I did my usual first steps;

# freebsd-update fetch install
# shutdown -r now
# portsnap fetch extract
# portsnap fetch update
# cd /usr/ports/*/zsh
# make install clean

At this point I got the error:

===>  zsh-5.2_1 pkg(8) must be version 1.6.0 or greater, but you have 1.5.4.
You must upgrade the ports-mgmt/pkg port first.

Well, the fix is simple:

# cd /usr/ports/ports-mgmt/pkg
# make deinstall reinstall

 

Published by

Guy Tabrar

*NIX Admin.